NEOCycle - Edge of the World Cyclocross Spectacular: CX - Men Cat 1/2/3
M Cat 1/2/3 (Men) - CX - Men Cat 1/2/3  Cyclocross Club
2017-09-10 14:45   Nations: 1   Starters: 22

Generated: 2018-09-24 09:18:19

RankBibNameTeamLicenseUCIIDTimeGap
1.21MIHALIK, MichaelJmac Cycling/Novacare245927 57:41
2.22VILLELLA, JordanCycle Smart300661 58:030'21"
3.195ETHERIDGE, CraigC3 Twenty20226484 59:161'34"
4.23KIEFFER, SamuelTexas Roadhouse399422 1:01:023'20"
5.25MCKAY, Brettbike ohio205998 1:01:303'48"
6.302MARTIN, Paul207549 1:02:184'36"
7.39SUPPAN, JasonRideOn310626 1:03:015'19"
8.260BORNER, ThomasCyclus Sports353622 1:03:175'35"
9.27GANSER, Jaybike ohio475458 58:11-1 lap
10.34LUIKART, RobParadise Garage Racing382731 58:29-1 lap
11.32MOLNAR, Nathanbike ohio430988 58:48-1 lap
12.571GEIGER, ShawnDynamic Physical Therapy Cycling p/b Pat301290 58:49-1 lap
13.38MUTH, Cory309938 59:03-1 lap
14.28THOMPSON, Brent278707 59:11-1 lap
15.33JACKSON, CameronSummit Freewheelers243794 59:25-1 lap
16.30GRIER, BenjaminParadise Garage275075 59:53-1 lap
17.36HUCK, ChristopherWells Fargo Advisors165499 1:01:17-1 lap
18.35CHAPPELL, ZacharySnakebite Racing358069 1:02:13-1 lap
19.29ILES, TravisAudi455735 1:03:06-1 lap
DNF284GALATI, DavidLa Prima Espresso Co. Racing412373 
DNF37POOLER, JamesRide On Wooster341874 
DNF40ZOLLARS, JaredThe Bicycle Hub468173 
DNS24WEEKS, MatthewLake Effect Cycling Team232237 
DNS26EVANS, BrentShining Star Cycling p/b the bicycle hub11037 
CrossMgr Requires support for the HTML5 Canvas.
Please upgrade to a more recent browser version.
For Internet Explorer (IE), you need version 9.0 or higher.

Current versions of Chrome, FireFox and Opera work fine.




Zoom
+









-
Time Slider   
CrossMgr Requires support for the HTML5 Canvas.
Please upgrade to a more recent browser version.
For Internet Explorer (IE), you need version 9.0 or higher.

Current versions of Chrome, FireFox and Opera work fine.

CrossMgr Requires support for the HTML5 Canvas.
Please upgrade to a more recent browser version.
For Internet Explorer (IE), you need version 9.0 or higher.

Current versions of Chrome, FireFox and Opera work fine.